[PATCH v1 0/6] aarch64: intrinsics refactors
via Sourceware Forge
forge-bot@forge-test.rdfm.org
Thu Oct 2 16:34:53 GMT 2025
Hi gcc-patches mailing list,
karmea01@sourceware.org has requested that the following forgejo pull request
be published on the mailing list.
Created on: 2025-10-02 16:30:31+00:00
Latest update: 2025-10-02 16:34:24+00:00
Changes: 6 changed files, 162 additions, 85 deletions
Head revision: karmea01/gcc-TEST ref km/aarch64-intrinsics-refactors/v1 commit 5f56d3425e5d22c562f253f864c856e735421795
Base revision: gcc/gcc-TEST ref trunk commit 60c6f92fb192352d784ab3153a9e11c19a3216a0 r16-4191-g60c6f92fb19235
Merge base: 60c6f92fb192352d784ab3153a9e11c19a3216a0
Full diff url: https://forge.sourceware.org/gcc/gcc-TEST/pulls/90.diff
Discussion: https://forge.sourceware.org/gcc/gcc-TEST/pulls/90
Requested Reviewers:
Minor refactors and documentation improvements. NFCI
ChangeLog:
* v1: Initial revision
Changed files:
- M: gcc/config/aarch64/aarch64-neon-sve-bridge-builtins.def
- M: gcc/config/aarch64/aarch64-sve-builtins-base.def
- M: gcc/config/aarch64/aarch64-sve-builtins-sme.def
- M: gcc/config/aarch64/aarch64-sve-builtins.cc
- M: gcc/config/aarch64/aarch64-sve-builtins.def
- M: gcc/config/aarch64/aarch64-sve-builtins.h
Karl Meakin (6):
aarch64: Document `DEF_*` macros
aarch64: Define `DEF_SVE_TYPE_SUFFIX` in terms of
`DEF_SVE_NEON_TYPE_SUFFIX`
aarch64: Use variadic arguments
aarch64: Delete duplicate `enum aarch64_simd_type` definition
aarch64: Reformat array initializers to be more readable
aarch64: Remove redundant `const` from `constexpr` variables
.../aarch64-neon-sve-bridge-builtins.def | 4 +-
.../aarch64/aarch64-sve-builtins-base.def | 22 ++++
.../aarch64/aarch64-sve-builtins-sme.def | 24 +++-
gcc/config/aarch64/aarch64-sve-builtins.cc | 105 ++++++++++++------
gcc/config/aarch64/aarch64-sve-builtins.def | 51 ++++++---
gcc/config/aarch64/aarch64-sve-builtins.h | 21 +---
6 files changed, 152 insertions(+), 75 deletions(-)
--
2.50.1
More information about the Test-list
mailing list