[Bug testsuite/16326] New: client.exp and local stap-server interactions

mcermak at redhat dot com sourceware-bugzilla@sourceware.org
Fri Dec 13 15:45:00 GMT 2013


https://sourceware.org/bugzilla/show_bug.cgi?id=16326

            Bug ID: 16326
           Summary: client.exp and local stap-server interactions
           Product: systemtap
           Version: unspecified
            Status: NEW
          Severity: normal
          Priority: P2
         Component: testsuite
          Assignee: systemtap at sourceware dot org
          Reporter: mcermak at redhat dot com

Created attachment 7321
  --> https://sourceware.org/bugzilla/attachment.cgi?id=7321&action=edit
proposed patch

client.exp doesn't work fine if local stap-server runs. If valid trust for it
exists, testcase fails like this:

FAIL: No new signing servers
FAIL: No longer trusted after revokation by host name
XPASS: New signing servers
FAIL: No longer trusted as a signer after revokation

If local stap-server is stopped but valid trust for it exists, then the
testcase result is:

FAIL: Verify existing online server list
FAIL: Verify all existing server list

These are duplicates (PR16325) and arise because `stap --list-servers=all`
returns one record (with address=offline port=unknown) and so
existing_online_servers != all_existing_servers.

So I guess it's better to stop local stap-server if it runs and revoke it's
trust at our testcase startup.

-- 
You are receiving this mail because:
You are the assignee for the bug.



More information about the Systemtap mailing list