[Bug translator/10300] Provide more macros for embedded-C functions
smakarov at redhat dot com
sourceware-bugzilla@sourceware.org
Wed Jun 13 17:51:00 GMT 2012
http://sourceware.org/bugzilla/show_bug.cgi?id=10300
Serguei Makarov <smakarov at redhat dot com> changed:
What |Removed |Added
----------------------------------------------------------------------------
CC| |smakarov at redhat dot com
--- Comment #1 from Serguei Makarov <smakarov at redhat dot com> 2012-06-13 17:51:19 UTC ---
While fixing PR10299, implemented a couple additional helper macros:
#define STAP_ARG_foo THIS->l_foo // automatically defined for each local
variable in a function
#define STAP_RETVAL THIS->__retval
(All embedded-C functions are now required to use these macros, because the
naming scheme for local variables is now subject to change arbitrarily.) This
work happens to double as progress on PR10300.
The next logical step would probably to implement a STAP_RETURN(val) macro
similar to the one described above. Note that not all tapsets would wind up
using it -- STAP_RETVAL would still have to be available since some tapsets do
tricky in-place editing on e.g. string return values and forcing them to go
through STAP_RETURN would introduce an additional unnecessary copy step.
--
Configure bugmail: http://sourceware.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the Systemtap
mailing list