[PATCH v3 2.6.39-rc1-tip 14/26] 14: x86: x86 specific probe handling
Srikar Dronamraju
srikar@linux.vnet.ibm.com
Tue Apr 19 05:57:00 GMT 2011
* Peter Zijlstra <peterz@infradead.org> [2011-04-18 18:55:00]:
> On Fri, 2011-04-01 at 20:05 +0530, Srikar Dronamraju wrote:
> > +/*
> > + * @reg: reflects the saved state of the task
> > + * @vaddr: the virtual address to jump to.
> > + * Return 0 on success or a -ve number on error.
> > + */
> > +void set_ip(struct pt_regs *regs, unsigned long vaddr)
> > +{
> > + regs->ip = vaddr;
> > +}
>
> Since we have the cross-architecture function:
> instruction_pointer(struct pt_regs*) to read the thing, this ought to be
> called set_instruction_pointer(struct pt_regs*, unsigned long) or
> somesuch.
Okay, will rename set_ip to set_instruction_pointer.
More information about the Systemtap
mailing list