[PATCH v3 2.6.39-rc1-tip 22/26] 22: perf: rename target_module to target

Srikar Dronamraju srikar@linux.vnet.ibm.com
Wed Apr 6 23:46:00 GMT 2011


> >  
> > -int show_available_funcs(const char *module, struct strfilter *_filter)
> > +int show_available_funcs(const char *elfobject, struct strfilter *_filter)
> >  {
> >  	struct map *map;
> >  	int ret;
> > @@ -1990,9 +1990,9 @@ int show_available_funcs(const char *module, struct strfilter *_filter)
> >  	if (ret < 0)
> >  		return ret;
> >  
> > -	map = kernel_get_module_map(module);
> > +	map = kernel_get_module_map(elfobject);
> >  	if (!map) {
> > -		pr_err("Failed to find %s map.\n", (module) ? : "kernel");
> > +		pr_err("Failed to find %s map.\n", (elfobject) ? : "kernel");
> 
> Hmm, these changes(module -> elfobject) are put back by the next patch.
> Could you check your patch stack?
> 

In the next patch, we move "map =
kernel_get_module_map(module/elfobject)" to a new function
available_kernel_funcs(). For example: Even after the next patch,
show_available_funcs() still takes elfobject and not module. If you want
to avoid this, then we would have to either introduce the
available_kernel_funcs() in this patch Or we could merge this and the
next patch. Both those solutions dont look clean to me.

-- 
Thanks and Regards
Srikar



More information about the Systemtap mailing list