[RFC] [PATCH 2.6.37-rc5-tip 4/20] 4: uprobes: Adding and remove a uprobe in a rb tree.

Peter Zijlstra peterz@infradead.org
Tue Jan 25 12:15:00 GMT 2011


On Thu, 2010-12-16 at 15:28 +0530, Srikar Dronamraju wrote:
> +/* Should be called lock-less */
> +static void put_uprobe(struct uprobe *uprobe)
> +{
> +       if (atomic_dec_and_test(&uprobe->ref))
> +               kfree(uprobe);
> +} 

Since this instantly frees the uprobe once ref hits 0, the
atomic_inc_not_zero() in find_uprobe() doesn't really make sense does
it?



More information about the Systemtap mailing list