RFC: Trivial version check change in signal.send.part3 in signal.stp
Frank Ch. Eigler
fche@redhat.com
Mon Jul 21 14:26:00 GMT 2008
Phil Muldoon <pmuldoon@redhat.com> writes:
> Corresponding bug: http://sourceware.org/bugzilla/show_bug.cgi?id=6752
> [...]
> probe _signal.send.part3 = kernel.function("send_sigqueue")
> {
> name = "send_sigqueue"
(This could just be probefunc().)
> -%( kernel_v > "2.6.25" %?
> +%( kernel_v > "2.6.25.10" %?
> task = $t
> sig = $q->info->si_signo
> %:
The parameter (task_struct *p -> *t) rename occurred in commit
ac6c215. It was after the 2.6.25 release, and included in 2.6.26.
Fedora's new naming convention is confusing the kernel_v test.
The test could be changed to ... >= "2.6.26" ..., or indeed
the translator's "kernel_v" expansion could be truncated to A.B.C.
I'd prefer the former change for now, although if there are many other
problematic cases with ">", and if non-fedora people also number their
kernels A.B.C.D, then the latter may make more sense.
- FChE
More information about the Systemtap
mailing list