I put the correct fix in upstream. (It's the same as Ananth's fix, though I committed before reading that message.) But AFAIK this could only come up in a situation where it was going to fail with an error anyway, because that case means the vmlinux file opened was unreadable or suchlike. Thanks, Roland