re-send: thread_info renamed to stack

Mike Mason mmlnx@us.ibm.com
Sun Aug 5 17:50:00 GMT 2007


Hi Wenji,

Yes, you're right, I got the version number wrong.  Thanks for the fix.

Mike

Wenji Huang wrote:
> Hi,
> 
>    There is small change for task_struct in sched.h ("since 2.6.22, 
> rename thread_info to stack  This finally renames the thread_info field 
> in task structure to stack, so that the assumptions about this field are 
> gone and archs have more freedom about   placing the thread_info 
> structure. "
> 
> So tapset/task.stp result in testsuite/buildok/task_test.stp failed in 
> kernel >=2.6.22.
> 
> Please review the patch, if there is no object, I will commit it.
> 
> Regards,
> Wenji
> 
> 
> 



More information about the Systemtap mailing list