Hitachi djprobe mechanism
Karim Yaghmour
karim@opersys.com
Wed Aug 3 14:50:00 GMT 2005
Just some short comments.
Satoshi Oshima wrote:
> I see.
>
> We should add another limitation to djprobe limitation list.
> Current list is ...
> ------------------------------------------
>
> limitation of djprobe
>
> djprobe user must avoid inserting a probe into the place below:
I guess you mean "instructions shorter than 5 bytes that are right
before ..."
> code includes relative jmp instruction
> code includes call instruction
> code includes int instruction
> functions that preempt current process such as sched() or might_resched()
Actually for this last one, you will likely find that a lot of
functions actually do result in scheduling possibilities. So
this last requirement is rather difficult to follow.
Generally, I think I've already explained well enough the reasons
why some assumptions currently being made warrant some serious
examination. Your response is certainly a step in the right direction,
and I encourage you to continue looking at these issues closely.
If nothing else, you've got people like Mathieu who genuinely
understand the implications and should help guide you further.
Karim
--
Author, Speaker, Developer, Consultant
Pushing Embedded and Real-Time Linux Systems Beyond the Limits
http://www.opersys.com || karim@opersys.com || 1-866-677-4546
More information about the Systemtap
mailing list