FW: recent kprobe work
Ananth N Mavinakayanahalli
ananth@in.ibm.com
Wed Jun 29 18:26:00 GMT 2005
On Wed, Jun 29, 2005 at 10:56:31AM -0700, Lynch, Rusty wrote:
> >I believe Dave was referring to our use of arch_init() rather than
> >arch_init_kprobe() or somesuch.
> >>
> >> Anyone have a problem with me kicking out a patch to move all the
> arch_*
> >> function names to kprobes_arch_* ?
> >
> >Hmm, I'd prefer to have the _kprobe() suffix rather than the prefix, as
> >we do now (arch_prepare/arm/disarm_kprobe()). How about making the call
> >in question arch_init_kprobe/kretprobe() instead?
>
> How about arch_init_kprobes() <kprobes instead of kprobe>, since this
> function is meant to initialize the architecture specific sections of
> the kprobes infrastructure (as opposed to a specific kprobe or kretprobe
> or jprobe or what ever else is next)?
>
> ... and then don't touch any of the other arch_ functions. (I was
> thinking we had some other arch_* functions that would be namespace
> problems, but now I realize they all have a kprobe specific component to
> them (like arch_prepare_kprobe)).
Sounds good!
Ananth
More information about the Systemtap
mailing list