Headaches building Source Navigator under Windows

Bruce Edson bruce@steptech.com
Tue Feb 26 12:30:00 GMT 2002

Just as another attempt at this, I tried what you suggested, namely putting
cl.exe in quotes.  Configure now runs to the end.  Yahoo!  Quite the stab in
the dark, Ian. I am not sure what was happening, maybe you could explain.

Now on to the next road block in the 'make' portion of the build.  This
seems to run along for a while without errors, although a few warnings,
until the following:

LINK : LNK6004: ./tix4181.exe not found or not built by the last incremental
link; performing full link
make[2]: Leaving directory `/snbuild/tix/win'
make[1]: Leaving directory `/snbuild/tix'
make[1]: Entering directory `/snbuild/itcl'
Making in itcl/win
make[2]: Entering directory `/snbuild/itcl/itcl/win'
make[2]: *** No rule to make target `itcl_bicmds.obj', needed by
make[2]: Leaving directory `/snbuild/itcl/itcl/win'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/snbuild/itcl'
make: *** [all-itcl] Error 2

Any thoughts?

-----Original Message-----
From: Ian Roxborough [mailto:irox@redhat.com]
Sent: Tuesday, February 26, 2002 12:07 PM
To: Bruce Edson
Cc: Mo DeJong
Subject: Re: Headaches building Source Navigator under Windows

A stab in the dark:

Are you setting to CC="cl.exe ...." before you run configure?


Bruce Edson wrote:
> Thanks for responding, Mo.
> I removed the host option and still get the same results.  I originally
> it there after my first attempt of a cygwin install.  That's been updated
> now, so it appears that the host option isn't needed.
> When configuring itcl/win, it attempts to cd into '../../../tcl/win' and
> fails.  Maybe I need to change something to get it cd into
> '../../../tcl8.1/win'.  If so what and where would I make the change?
> Ran grep in snbuild/tcl8.1 directory and got the expected results,
> 's%@CONFIGDIR@%win%g'.  I agree, it looks mighty strange that its playing
> the unix path here.
> I also noticed that when creating tclconfig.sh and tkconfig.sh, they were
> created in snbuild/tcl8.1/unix and snbuild/tk8.1/unix subdirectories.
> was shortly after receiving the message '> cd: can't cd to
> ../../../tcl/win'.  Can anyone think of why?
> Bruce
> -----Original Message-----
> From: Mo DeJong [mailto:supermo@bayarea.net]
> Sent: Tuesday, February 26, 2002 12:48 AM
> To: sourcenav
> Subject: Re: Headaches building Source Navigator under Windows
> On Fri, 22 Feb 2002 13:07:46 -0800
> Bruce Edson <bruce@steptech.com> wrote:
> > I went to Cygwin site and figured out how to get the rest of the
> utilities.
> > So, now I am at the point where the 'configure' as described in the
> > file, breaks with the following errors.
> > ../sourc/configure --host=i686-pc-cygwin
> > --prefix="c:/docume~1/bruce/hpkeck~1/snkeck~1/opt/sourcenav"
> Well, this looks ok. Any particular reason you passed a --host option
> > 2.
> > configuring in itcl/win
> > running /bin/sh ../../../../source/itcl/itcl/win/configure
> > --host=i686-pc-cygwin --target=i686-pc-cygwin
> > '--prefix=c:/docume~1/bruce/hpkeck~1/snkeck~1/opt/sourcenav'
> > --cache-file=../../../config.cache
> --srcdir=../../../../source/itcl/itcl/win
> > cd: can't cd to ../../../tcl/win
> Humm, I would think that should be looking in ../tcl8.1/win, but I
> am not sure if it matters.
> > 6.
> > Configuring snavigator...
> > checking for Tcl configuration script... (cached)
> > /snbuild/tcl8.1/unix/tclConfig.sh
> > checking for Tk configuration script... (cached)
> > /snbuild/tk8.1/unix/tkConfig.sh
> > checking for Tcl headers in the source tree... (cached) configure:
> > Can't find any Tcl headers
> > Configure in /snbuild/snavigator failed, exiting.
> Well, this is not right. It should be checking in tcl8.1/win not the
> unix subdir. Me thinks something has gone wrong in tcl8.1/configure.in
> where it selects either the unix subdir or the win subdir based on the
> --host setting.
> Go into your $build/tcl8.1 dir and run this grep:
> grep CONFIGDIR config.status
> You should get a result like:
> s%@CONFIGDIR@%win%g
> If you get "unix" instead of "win" then that is the problem. You could try
> to not pass a --host option and see if that makes any diff.
> cheers
> Mo

More information about the Sourcenav mailing list