Invalid command "sn_tcl_tk_init"

Mo DeJong mdejong@cygnus.com
Sun Aug 6 13:18:00 GMT 2000


> Hello,
> 
> I am new to this list. As I had difficulties in starting Source
> Navigator logged in as normal user after having it installed as root (on
> Linux SuSE 6.4) I searched the archive. I concluded from the
> contributions that one of the available patches fixes the problem. Thus,
> I tried those patches but without success. Could anybody point me into
> the right direction and tell me the actual status?
> 
> Thanks,
> Helmut

You applied this patch?
ftp://sources.redhat.com/pub/sourcenav/releases/patches/0001-spolk-000725-patch

That should have fixed it. This is the part that fixes that
problem.

Index: snavigator/gui/Makefile.am
===================================================================
RCS file: /cvs/cvsfiles/devo/snavigator/gui/Makefile.am,v
retrieving revision 1.27.2.2.2.3.4.4
diff -c -2 -p -r1.27.2.2.2.3.4.4 Makefile.am
*** snavigator/gui/Makefile.am  2000/02/11 23:48:34     1.27.2.2.2.3.4.4
--- snavigator/gui/Makefile.am  2000/07/25 19:19:57
*************** tclIndex: $(prog_DATA)
*** 43,47 ****
          here=`pwd`; cd $(srcdir) && \
          rm -f tclIndex && \
!         echo "source $(ITCL_MKINDEX_DIR)/itcl_mkindex.tcl; itcl_mkindex 
$(SN_GUI_DIR)" | @ITCL_SH@
  
  all-local: tclIndex
--- 43,48 ----
          here=`pwd`; cd $(srcdir) && \
          rm -f tclIndex && \
!         echo "source $(ITCL_MKINDEX_DIR)/itcl_mkindex.tcl; itcl_mkindex 
$(SN_GUI_DIR)" | @ITCL_SH@ && \
!         chmod 644 tclIndex


You just need a chmod.

Mo DeJong
Red Hat Inc


More information about the Sourcenav mailing list