branch probability hinting
matthew green
mrg@cygnus.com
Wed Feb 28 17:04:00 GMT 2001
matthew green wrote:
>
> i like this, but i don't like the name very much. in NetBSD,
> we've added predict_true() and predict_false().
Well, builtin is the default name for compiler um.. well.. builtins.
It's been around for a while.
uh, i mean, we define predict_true() to make use of this feature :-)
Unless you meant the name that Frank chose, yeah, it could be better.
Personally, I like expect as a name for it, tells you what you are
telling the compiler to expect to happen.
i don't really care much either way, but "UNLIKELY" is very ugly to me.
.mrg.
More information about the Sid
mailing list