catch (...)

reentrant reentrant@yahoo.com
Tue Aug 7 08:49:00 GMT 2001


> #define PtW32CatchAll \
>         catch( ptw32_exception & ) { throw; } \
>         catch( ... )

Seems like it might be more appropriate (possibly required by the pthread
standard?) for this to have a prefix of "pthread_" and a suffix of "_np" for
non-portable; potentially "pthread_w32_catch_all_np" or similar instead of
"PtW32CatchAll" ?  The same holds true for other PtW32 prefixed items.  It
seems wrong to introduce another namespace.

Dave


__________________________________________________
Do You Yahoo!?
Make international calls for as low as $.04/minute with Yahoo! Messenger
http://phonecard.yahoo.com/



More information about the Pthreads-win32 mailing list