newlib_cv_ vs libc_cv_ autoconf cache vars prefix

Mike Frysinger vapier@gentoo.org
Fri Jan 28 09:44:20 GMT 2022


the newlib/libgloss configure scripts use both libc_cv_ and newlib_cv_ as
their autoconf cache var prefixes.  this really should be just one name.
i'm inclined to use newlib_cv_ rather than the more generic libc_cv_.  any
preferences or reasons to pick one or the other ?

libgloss also has cache vars.  i'm inclined to have it use newlib_cv_ too
since, as a project, it's carved out the namespace, and doesn't really need
its own libgloss_cv_ prefix.
-mike
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://sourceware.org/pipermail/newlib/attachments/20220128/b6bb317d/attachment-0001.sig>


More information about the Newlib mailing list