Newlib fails to build arm-none-eabi target on last release (

Tamar Christina
Fri Sep 22 12:13:00 GMT 2017


Yes the build fails for some reason when a relative path is used for configure,

I'm looking into it.

In the mean time you can work around it by using an absolute path when invoking configure.

From: <> on behalf of Agustin Henze <>
Sent: Friday, September 22, 2017 10:50 AM
Subject: Newlib fails to build arm-none-eabi target on last release (

Hi, I was trying to build the last release ( of newlib and it is
failing. Then I have tried building `origin/master` and I get the same error.

config.status: error: cannot find input file: `cpu-init/'
sed: can't read Makefile: No such file or directory
make[6]: Entering directory
make[6]: *** No rule to make target 'all'.  Stop.

Trying to figure out what is happening, it seems that `libgloss/`
is using the same `config.status` generated for a sub-folder leaving all paths
broken off by one. You can find the line that I'm talking about[0].

I have setup a gitlab instance to show easily how to reproduce the error, you
can see the `configure` parameters here[1] and you can find the full output of
the build here[2].



More information about the Newlib mailing list