[PATCH 1/8] Rename __sentinel to __null_sentinel
Sebastian Huber
sebastian.huber@embedded-brains.de
Tue Apr 4 07:05:00 GMT 2017
From: pfg <pfg@FreeBSD.org>
GCC 5 uses a conflicting __sentinel definition in include/c++/bits/stl_algo.h
Reported by: matteo
---
newlib/libc/include/sys/cdefs.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/newlib/libc/include/sys/cdefs.h b/newlib/libc/include/sys/cdefs.h
index f569fc4..1e3c6b0 100644
--- a/newlib/libc/include/sys/cdefs.h
+++ b/newlib/libc/include/sys/cdefs.h
@@ -464,7 +464,7 @@
#endif
#if __GNUC_PREREQ__(4, 0)
-#define __sentinel __attribute__((__sentinel__))
+#define __null_sentinel __attribute__((__sentinel__))
#define __exported __attribute__((__visibility__("default")))
/* Only default visibility is supported on PE/COFF targets. */
#ifndef __CYGWIN__
@@ -473,7 +473,7 @@
#define __hidden
#endif
#else
-#define __sentinel
+#define __null_sentinel
#define __exported
#define __hidden
#endif
--
1.8.4.5
More information about the Newlib
mailing list