[PATCH] Unify names of all lock objects

Freddie Chopin freddie_chopin@op.pl
Mon Jan 30 09:09:00 GMT 2017

On Mon, 2017-01-30 at 07:55 +0100, Freddie Chopin wrote:
> Alternatively I could do "__<name>_[non]recursive_lock" and this
> would
> not conflict with any function name, but it's not really better than
> the "object" suffix.

Another option: "__<name>_[recursive_]mutex".


More information about the Newlib mailing list