Problem with building PDF documentation

Corinna Vinschen
Wed Dec 9 09:27:00 GMT 2015

Jon?  Any idea?

On Dec  8 10:08, Freddie Chopin wrote:
> Hello!
> I've tried building the most recent newlib for arm-none-eabi and I 
> encountered a problem when building PDF documentation. I guess this problem is 
> specific to the very recent version of TEX utils on my system (Arch Linux). I 
> attach the log from the console - the part where the generation of libc.pdf 
> fails. I also attach libc.log file generated during compilation. Both files 
> are compressed, because they are over 100kB
> I have a very similar problem with building PDF for binutils (I reported that 
> on binutils mailing list). However generated as.pdf file looks OK (I did not 
> inspect it very thoroughly), while in the libc.pdf document there is no index 
> - there is a chapter for index, but all it has is this:
> > Document Index
> > (Index is nonexistent)
> Here are the versions of relevant tools:
> $ texi2dvi --version
> texi2dvi (GNU Texinfo 6.0) 6363
> Copyright (C) 2015 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> $ pdfetex --version
> pdfTeX 3.14159265-2.6-1.40.16 (TeX Live 2015/Arch Linux)
> kpathsea version 6.2.1
> Copyright 2015 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
> There is NO warranty.  Redistribution of this software is
> covered by the terms of both the pdfTeX copyright and
> the Lesser GNU General Public License.
> For more information about these matters, see the file
> named COPYING and the pdfTeX source.
> Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
> Compiled with libpng 1.6.18; using libpng 1.6.19
> Compiled with zlib 1.2.8; using zlib 1.2.8
> Compiled with poppler version 0.37.0
> The texlive package I have is 2015.37497-5.
> I guess it it also worth noting that I had no trouble building PDF 
> documentation for newlib (and binutils) at the end of Semtember (at 28th 
> exactly) - I used the most recent newlib sources and the most recent software 
> packages (at that time). I tried this again with the same version ( 
> f296bb3569839b0217ec1a775165d239877e3548 ) and it fails too, so I guess the 
> problem is related to tex version (or some component that is used by tex) that 
> I use.
> If any more info is needed, just let me know.
> Regards,
> FCh


Corinna Vinschen
Cygwin Maintainer
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <>

More information about the Newlib mailing list