Newlib 2.1.0 not building

Jeff Johnston
Tue Jan 7 22:43:00 GMT 2014

Actually, this is caused because of a relative file path.

The right way to fix this is to change the arm/ to use
ac_abs_srcdir instead of srcdir as part of host_makefile_frag.  I have
made the change and checked it in, but had problem getting an arm
toolchain to build with.

Please verify the change I made works.

-- Jeff J.

On 01/03/2014 09:40 AM, Agustin Henze wrote:
> On 12/27/2013 05:12 PM, Legimet  wrote:
>> Hi, I think I found a bug in Newlib 2.1.0. I tried building with the following:
>> ./configure --target=arm-none-eabi --prefix=/usr/local
>> --enable-interwork --enable-multilib --with-gnu-as --with-gnu-ld
>> --disable-nls --with-float=soft --disable-werror
>> But when make enters arm-none-eabi/thumb/libgloss/arm/cpu-init, the
>> build fails with the message
>> *** No rule to make target
>> `../../../.././libgloss/arm/../config/', needed by
>> `Makefile'.  Stop.
> I confirm, I get the same error. Please find attached a patch that I applied to
> fix this.
> Cheers,

More information about the Newlib mailing list