[PATCH] Use offsetof instead of magic number in scandir()

Sebastian Huber sebastian.huber@embedded-brains.de
Thu Mar 28 11:02:00 GMT 2013


Hello,

this patch helps to avoid problems like this:

https://www.rtems.org/bugzilla/show_bug.cgi?id=1394

Why do we need a 4 byte alignment of allocated size?

-- 
Sebastian Huber, embedded brains GmbH

Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone   : +49 89 189 47 41-16
Fax     : +49 89 189 47 41-09
E-Mail  : sebastian.huber@embedded-brains.de
PGP     : Public key available on request.

Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.



More information about the Newlib mailing list