newlib.git: cvs-to-git mirror imminent

Jim Meyering
Fri Oct 14 19:22:00 GMT 2011

Roland McGrath wrote:

>> When I run this,
>>    cvs -d co newlib
>> I get a newlib directory, but it contains none of the directories
>> you list below.
> When I run it, I get a directory called src:
> 	ChangeLog      COPYING3.LIB	 lt~obsolete.m4  move-if-change*
> 	compile*       COPYING.LIB	 ltoptions.m4	 newlib/
> 	config/        COPYING.LIBGLOSS  ltsugar.m4	 README
> 	config.guess*  COPYING.NEWLIB	 ltversion.m4	 README-maintainer-mode
> 	config.rpath*  depcomp*		 Makefile.def	 src-release
> 	config.sub*    etc/	 symlink-tree*
> 	configure*     install-sh*	 Makefile.tpl	 texinfo/
>   libgloss/	 makefile.vms	 ylwrap*
> 	contrib/       libtool.m4	 missing*
> 	COPYING        ltgcc.m4		 mkdep*
> 	COPYING3	 mkinstalldirs*
> That's what I'd expect from looking at
> where it says:
> 	newlib          -a naked-newlib naked-libgloss naked-texinfo src-support
>> The cvs-to-git mirroring configs for binutils and gdb
>> use significantly different lists of excluded directory names,
>> but I'll assume you want to exclude all directories under src/
>> *except* the six you listed.
> I think it should match what "cvs co newlib" does, as shown above.
>> Since the above checkout command doesn't do what you seem to want,
>> what command should I use to cvs-checkout all of the files you'd
>> like to see in the git mirror?
> Since it does do what I said it did, I'm not sure what else I can say.

I was actually using this command,

    cvs -d co -d newlib-cvs newlib

to contrast with a sibling directory, newlib-git.
Unfortunately, when you use co's -d DIR argument like that
it makes the modules bits malfunction.

Once I dropped the -d DIR, I saw the same list of files you did.

With that, I've replaced the old newlib.git with a new one containing
all of src/ and excluding all directories but those six.;a=summary

Let me know if that's ok.
Modulo $keyword$ differences, there's only one difference:
djunpack.bat is a nonempty file in top-level git repo, yet absent in cvs

It's probably due to games someone played with Attic and/or ,v files.
I can remove it from git (in an internal staging dir) if it's a problem,
and that will propagate safely to the public mirror.

While everyone in the newlib group has write/push access to this git
repository, please don't use it.  If you commit anything there (anything
at all) it'll cause the synchronization to fail the next time a cvs
change prompts an automated push into the mirrored .git directory.

More information about the Newlib mailing list