Hints on compiling Newlib

Ian Seyler ian.seyler@returninfinity.com
Tue Jun 21 18:34:00 GMT 2011

I tried the exact same steps I was using before on Arch Linux (another
64-bit VM) and it worked correctly.

During the compile it was not inserting "-m32" into the compile
commands. Any ideas why this would be happening or where I can remove
it from? I have no idea where it is pulling that argument from.

I ended up creating the files needed to define my OS so I could also do this:
../newlib-1.19.0/configure --target=x86_64-pc-baremetal

Looks like everything is working well. I compiled a simple "Hello
world" example using printf() and got the expected results.


On Thu, Jun 16, 2011 at 9:01 PM, Mike Frysinger <vapier@gentoo.org> wrote:
> On Thursday, June 16, 2011 08:59:21 Ian Seyler wrote:
>> I run this to generate the makefile:
>> ../newlib-1.19.0/configure --target=x86_64-pc-none
> pretty sure you want to be using --host here.  might also try x86_64-elf.
> -mike

Ian Seyler | Founder / Lead Programmer | Return Infinity |
ian.seyler@returninfinity.com | visit us at www.returninfinity.com

More information about the Newlib mailing list