Problem building newlib for arm

Jeff Johnston
Tue May 13 00:44:00 GMT 2008

davidgf wrote:
> Hello,
> I've been looking to solve this error but I can't find much information
> about it.
> When I compile newlib (gcc and binutils too) for ARM (Game Boy) I got this
> error:
> configure: error: can not find install-sh or in .. ./.
> I have installed automake, autoconf, and all the required stuff. Where is
> the problem?
> I unzip the source and I run ./configure --target=arm-thumb-elf. Then I run
> make.
> Thanks.
> David
You'll have to provide more details.  What version of newlib are you 
trying to use?

For starters, you should specify either arm-elf or thumb-elf as your 
target.  IIRC, arm-elf builds arm with thumb support being a multilib 
triggered via the -mthumb option.

You cannot configure directly in the newlib subdirectory.  The newlib 
tarball is actually the top-level src directory with newlib and libgloss 
subdirectories included.  You configure from the top-level.

If you have linked the newlib and libgloss subdirectories into another 
source directory, check to see if the top-level merged directory has the 
file: install-sh.  If not, add it by running automake --add-missing in 
that top-level directory.

-- Jeff J.

More information about the Newlib mailing list