PATCH: ARMV7M support

Shaun Jackman sjackman@gmail.com
Thu Mar 23 23:27:00 GMT 2006


On 3/23/06, Mark Mitchell <mark@codesourcery.com> wrote:
> Shaun Jackman wrote:
>
> > Can you seperate the bare-metal and dependency (_exit and stdio)
> > component from the ARMv7M componenet of the patch? Non-ARMv7M targets
> > also benefit from your bare-metal/dependency work. I found the patch
> > difficult to read with the two matters mixed.
>
> The dependency work (_exit.c, avoiding initialise_monitor_handles) is
> actually already independent of ARM V7M; those changes apply to all ARM
> configurations.  I could break the patch apart to make that more
> obvious, if necessary.
...

I'd appreciate seeing your work posted as two patches. It would make
it easier to review,  separating the fixing of current stuff from
adding new stuff. I also find unified diffs (-u) easier to read than
context diffs (-c), but I'm happy to submit to the list's collective
preference.

Cheers,
Shaun


More information about the Newlib mailing list