Problem while building newlib on solaris with target decstation-ultrix, where is crt0.o ?

Laurent Eschenauer
Tue Nov 21 21:17:00 GMT 2000


I just subscribed to this list since I have a problem with newlib 1.8.1
(But I also tried 1.8.2, 1.7.1, ...)

I want to build gcc as a cross-compiler for the mips-ultrix
architecture, the gcc compilation worked fine,
I also installed the headers of the decstation-ultrix architecture in
the proper path, now all I need to use my new compiler is the file
crt0.o and that's why I need to install newlib.

Everything goes fine during the installation process of newlib since I
have the proper header file installed, my decstation-ultrix-gcc is going
fine,... but it exit with an error at the creation of the crt0.o file.

Looking at the Makefile of this specific architecture (in
/newlib-1.8.2/newlib/libc/sys/decstation/Makefile) I read :

        cp /lib/crt0.o crt0.o

But in other architecture you actually have the proper crt0.c file and
you compile it.

Does this mean that you don't have access to the proper sources for that
system and are just using the crt0.o already present on the target
system ? In that case my only solution (I have no clue where to find it)
is to find a decstation and get that file ? And that means newlib can't
be used for cross-compilers towards that architecture.

Or am I missing something about that specific architecture ?

Sorry if I'm completely out of topic !


Laurent Eschenauer

More information about the Newlib mailing list