make error on redhat 6.2and celeron 400

Michael Sokolov msokolov@ivan.Harhan.ORG
Tue Jul 18 09:33:00 GMT 2000 wrote:

> My cpu is celeron 400.I don't which target I should use.
> I have tried i386-aout,i386-coft,i386-elf when I run configure.

I assume you meant i386-coff, not "i386-coft". Basically, you choose the target
you want, depending on whether you want to work in an a.out, COFF, or ELF
object module environment. ELF is generally preferred these days, so start
trying with i386-elf.

> But when I make,I got the following error:
> /bin/sh:i386-*-gcc command not found

You have to have a cross compiler first before you can build a library for the
target system. Newlib is designed to be built together with the rest of the
toolchain. You need to build the whole toolchain, preferably in one swoop, as
described in the CrossGCC FAQ at

Michael Sokolov		Harhan Engineering Laboratory
Public Service Agent	International Free Computing Task Force
			International Engineering and Science Task Force
			DALLAS TX 75204-5852 USA

Phone: +1-214-824-7693 (Harhan Eng Lab office)
E-mail: msokolov@ivan.Harhan.ORG (ARPA TCP/SMTP) (UUCP coming soon)

More information about the Newlib mailing list