[newlib-cygwin/main] RISC-V: memset() size optimized version: Rename local labels
Jeff Johnston
jjohnstn@sourceware.org
Fri Apr 11 20:50:02 GMT 2025
https://sourceware.org/git/gitweb.cgi?p=newlib-cygwin.git;h=b7106be22824061c6164f9c3c544ddf023a1ee48
commit b7106be22824061c6164f9c3c544ddf023a1ee48
Author: m fally <marlene.fally@gmail.com>
Date: Thu Apr 10 13:23:07 2025 +0200
RISC-V: memset() size optimized version: Rename local labels
Rename local labels to improve readability.
Reviewed-by: Christian Herber <christian.herber@oss.nxp.com>
Signed-off-by: m fally <marlene.fally@gmail.com>
Diff:
---
newlib/libc/machine/riscv/memset.S | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/newlib/libc/machine/riscv/memset.S b/newlib/libc/machine/riscv/memset.S
index fac0f73a2..943835dc5 100644
--- a/newlib/libc/machine/riscv/memset.S
+++ b/newlib/libc/machine/riscv/memset.S
@@ -15,15 +15,15 @@
memset:
#if defined(PREFER_SIZE_OVER_SPEED) || defined(__OPTIMIZE_SIZE__)
mv a3, a0
- beqz a2, 2f
+ beqz a2, .Ldone
-1:
+.Lset:
sb a1, 0(a3)
add a2, a2, -1
add a3, a3, 1
- bnez a2, 1b
+ bnez a2, .Lset
-2:
+.Ldone:
ret
#else
More information about the Newlib-cvs
mailing list