[newlib-cygwin] Rename __sentinel to __null_sentinel

Corinna Vinschen corinna@sourceware.org
Tue Apr 4 09:44:00 GMT 2017


https://sourceware.org/git/gitweb.cgi?p=newlib-cygwin.git;h=086730fb14c1c4171764e605d7510e33f0fc34ed

commit 086730fb14c1c4171764e605d7510e33f0fc34ed
Author: pfg <pfg@FreeBSD.org>
Date:   Tue Apr 4 09:04:52 2017 +0200

    Rename __sentinel to __null_sentinel
    
    GCC 5 uses a conflicting __sentinel definition in include/c++/bits/stl_algo.h
    
    Reported by:	matteo

Diff:
---
 newlib/libc/include/sys/cdefs.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/newlib/libc/include/sys/cdefs.h b/newlib/libc/include/sys/cdefs.h
index f569fc4..1e3c6b0 100644
--- a/newlib/libc/include/sys/cdefs.h
+++ b/newlib/libc/include/sys/cdefs.h
@@ -464,7 +464,7 @@
 #endif
 
 #if __GNUC_PREREQ__(4, 0)
-#define	__sentinel	__attribute__((__sentinel__))
+#define	__null_sentinel	__attribute__((__sentinel__))
 #define	__exported	__attribute__((__visibility__("default")))
 /* Only default visibility is supported on PE/COFF targets. */
 #ifndef __CYGWIN__
@@ -473,7 +473,7 @@
 #define	__hidden
 #endif
 #else
-#define	__sentinel
+#define	__null_sentinel
 #define	__exported
 #define	__hidden
 #endif



More information about the Newlib-cvs mailing list