n3891 s/shared_mutex/shared_timed_mutex/ is now in C++14
Ed Smith-Rowland
3dw4rd@verizon.net
Thu Feb 20 15:33:00 GMT 2014
> OK, Jakub thinks it's better to change this now, not for 4.9.1, so if
> the testsuite all passes (which it should do) then please go ahead and
> commit this to trunk.
>
> I'd prefer something descriptive for the ChangeLog entry rather than
> the sed command, maybe just move your first line to be the comment for
> the header change:
>
> * include/std/shared_mutex: Rename shared_mutex to shared_timed_mutex.
Testing was clean on x86_64-linux.
Just had a thought though: should I move the test case directory to
match the new class name also?
More information about the Libstdc++
mailing list