On Mon, Sep 3, 2012 at 2:15 AM, Daniel Krügler <daniel.kruegler@gmail.com> wrote: >[...] > should name the parameters as _InputIterator1 and _InputIterator2, resp, > because the code does multi-pass traversal. Suggested change would > be I agree with these points and changed the code. The overall question stands, are these the best interfaces for the job?