[v3] Remove algos code duplication

Paolo Carlini paolo.carlini@oracle.com
Tue Mar 27 09:04:00 GMT 2012


Hi,
>     Maybe it is simply time to merge what has been done by Howard and 
> Paolo in libstdcxx_so_7-branch. I will take a closer look to it and 
> hope that Howard will tell us if there is anything wrong in merging 
> this work now.
Realistically, I don't think Howard can provide further guidance today, 
give his strong involvement with clang. I mentioned him just to make 
sure people have all the "keywords" to find the relevant old exchanges 
in the mailing list.

I suppose we want indeed to review the work that Chris did (with some 
inputs from Howard) and recheck that it's still *correct* and *as simple 
as possible* today, given real rvalue references, etc. In terms of 
testing probably we want either to add a proxy iterator to the testsuite 
infrastructure and double check that we don't regress when we 
instantiate all the algorithms with it, or just use 
vector<bool>::iterator for that. I'm not sure the latter is nasty enough 
(as proxy iterator). Maybe Daniel too (in CC) can provide some help 
about this.

Thanks,
Paolo.



More information about the Libstdc++ mailing list