known duplicate code

Benjamin Kosnik bkoz@redhat.com
Fri Sep 15 13:57:00 GMT 2006


> Those two would be very good to have. I'd suggest swapping the order of
> the template parameters of enable_if so that the bool is first as in IF,
> cond_type, whatever you want to call it.

It would be nice to have conditional_type also able to work on
std::tr1::true_type and std::tr1::false_type.

Then we could typedef these (somewhat) ungainly types.

-benjamin



More information about the Libstdc++ mailing list