[v3] remove non-standard basic_filebuf members, fd, FILE filebufs

Nathan Myers ncm-nospam@cantrip.org
Mon Apr 29 22:54:00 GMT 2002


Phil Edwards <phil@jaj.com> writes:
> 
>   template<typename _CharT, typename _Traits = std::char_traits<_CharT> >
>     class file_filebuf : public std::basic_filebuf<_CharT, _Traits>
> | 
> | How about naming this class cfile_filebuf instead?  This highlights the
> | point of FILE* compatability, and follows the <c*> header naming 
> | convention.

I agree, partly.  There really are C FILEs, not generic files.  
I suggest "c_file_buf".  

I agree with Gaby that the <c*> header naming convention is not 
closely related.  Still, that *is* where the 'c' prefix came from.  
According to the originator of the convention, those headers were 
distinguished by it as representing our unfortunate C inheritance, 
which we hoped someday to transcend (and deprecate).  

Nathan Myers
ncm at cantrip dot org



More information about the Libstdc++ mailing list