> I think the below patch is a better approach: It simplifies the code, > making it smaller instead of bigger. I agree. I just didn't know where I would end when I started, so this is what I got... Martin