[PATCH] Get rid of ASM_SIZE_DIRECTIVE (take 2)

Pedro Alves palves@redhat.com
Wed Sep 19 09:29:00 GMT 2012


On 09/18/2012 07:57 PM, Carlos O'Donell wrote:
> On 9/18/2012 1:06 PM, Roland McGrath wrote:
>> That looks fine to me, though I am having second thoughts about the exact
>> choice of name.  SYMBOL_SIZE doesn't really communicate that it computes
>> based on ., i.e. that the placement of the macro relative to assembly code
>> following the symbol is crucial.  Good names are not coming to mind just now.
> 
> Imply that it's computed: SYMBOL_CALC_SIZE?
> 
> Imply that it's positional: SYMBOL_HERE_SIZE?

FUNCTION_END
FUNCTION_ENDS_HERE

SYMBOL_END
SYMBOL_ENDS_HERE

/me loves a good bikeshed :-)

-- 
Pedro Alves



More information about the Libc-ports mailing list