[PATCH] Get rid of ASM_SIZE_DIRECTIVE
Roland McGrath
roland@hack.frob.com
Mon Sep 17 19:25:00 GMT 2012
Having helper macros that we use in our code is certainly fine, and
appropriate when code using the macros is more concise, easier to maintain,
etc. That's a separate issue from de-conditionalizing things.
ASM_SIZE_DIRECTIVE is a useful macro, though it has a very poor choice of
name. The macro looks like it should expand just to ".size", like the
ASM_GLOBAL_DIRECTIVE expanded just to ".globl". We don't need a macro for
that. A shorthand macro is most useful when it has a short name.
More information about the Libc-ports
mailing list