[PATCH] Get rid of ASM_SIZE_DIRECTIVE

Marek Polacek polacek@redhat.com
Mon Sep 17 15:22:00 GMT 2012


On Mon, Sep 17, 2012 at 11:03:50AM -0400, Carlos O'Donell wrote:
> Did we agree that it's easier to read ".size ..." and that a macro for this is just superfluous?

Since we only support ELF, and we got rid of ASM_GLOBAL_DIRECTIVE,
and ASM_TYPE_DIRECTIVE{,_PREFIX}, removal of ASM_SIZE_DIRECTIVE,
which is also remnant from not-only-ELF era now, looks like another
logical step.

	Marek



More information about the Libc-ports mailing list