[PATCH] [RFC] y2038: nptl: Convert pthread_cond_{clock|timed}wait to support 64 bit time
Lukasz Majewski
lukma@denx.de
Mon Aug 24 17:50:59 GMT 2020
Hi Florian,
> * Lukasz Majewski:
>
> > I'm a bit puzzled here. It is a warning in fact despite I've guarded
> > the function in question with:
> > libpthread_hidden_{proto|def} (futex_abstimed_wait_cancelable64)
>
> I think the linknamespace test attempts to descend into
> futex_abstimed_wait_cancelable64 because it its name is in the public
> (non-implementation) namespace.
>
> Try naming it __futex_abstimed_wait_cancelable64.
Indeed, adding the "__" prefix fixed the issue.
And this "__" prefix is not needed in futex-internal.h functions as
those are "pasted" into source code by C preprocessor ....
Thanks Florian for help :-)
>
> Thanks,
> Florian
>
Best regards,
Lukasz Majewski
--
DENX Software Engineering GmbH, Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-59 Fax: (+49)-8142-66989-80 Email: lukma@denx.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 488 bytes
Desc: OpenPGP digital signature
URL: <https://sourceware.org/pipermail/libc-help/attachments/20200824/cac4355e/attachment.sig>
More information about the Libc-help
mailing list