Building and installing a new version of GLIBC on CentOS

Carlos O'Donell carlos@redhat.com
Fri Jul 19 03:59:00 GMT 2019


On 7/18/19 11:56 PM, Ian Trudel wrote:
> My system requires a newer version of GLIBC and I had a partial success so
> far. Building 64 bit works without a hitch; the installation failed to
> complete but I suspect it is because of the older 32 bit libm.so.
> 
> Unfortunately, building a 32 bit version fails early. I searched around on
> the web to find the proper way to build GLIBC version 2.29 for 32 bit but
> nothing worked.
> 
> Having an old 32 bit and a new 64 bit libraries mess up the locale, e.g.
> utf-8 vs utf8, and even prevent some apps to start.
> 
> I truly need a full replacement. Installing GLIBC in /opt would not work
> due to my system requirements.
> 
> Anyone would be so kind to help me? :)

I would not recommend upgrading your system glibc. It requires expert
level knowledge not to break your system.

Can you run your application in a container with a distribution that it
was intended to work with?

-- 
Cheers,
Carlos.



More information about the Libc-help mailing list