glibc 2.2.3 configure fails with "The x86_64 is not supported"

Eric Gunther egunther@warwick.net
Mon Jan 14 17:58:00 GMT 2019


Hi,

Im trying to use blender 2.8 on an opensuse 42.3 machine.  When I try
to run blender 2.8 I get an error that indicates I need glibc 2.23  I
have glibc   2.22.  So what I think I want to do is build glibc 2.2.3
and use patchelf to run the program because I am using a blender as I
downloaded to run without installing or building.

I am not very good with this sort of thing but it seems that should be
fairly easy.

So I downloaded glibc 2.2.3 and unpacked it. I entered the glibc-2.2.3
directory.  I made a directory (_build) and entered it.  I typed :
 ../configure --enable-kernel=4.4.165-81-default --prefix=/usr

and got:

loading site script /usr/share/site/x86_64-unknown-linux-gnu
loading cache ./config.cache
checking host system type... x86_64-unknown-linux-gnu
checking sysdep dirs... configure: error: The x86_64 is not supported.


I am thinking that it isn't possible that x86_64 is not supported and
that something is wrong with the 'name' of the computer or maybe I
downloaded the wrong glibc-2.2.3.  Also uname -r gives: 
4.4.165-81-default

another question:

Is glibc 2.23 the same as glibc 2.2.3
 


Thanks for any help,

-eg



More information about the Libc-help mailing list