glibc 2.18/2.17 compatibility

Allin Cottrell cottrell@wfu.edu
Sat Aug 31 16:27:00 GMT 2013


On Sat, 31 Aug 2013, Ondøej Bílka wrote:

> On Sat, Aug 31, 2013 at 09:42:02AM -0400, Allin Cottrell wrote:
>> On Fri, 30 Aug 2013, Allin Cottrell wrote:
>>
>>> This is a follow-up to my posting of August 19,
>>> http://sourceware.org/ml/libc-help/2013-08/msg00036.html
>>>
>>> I had reported that various programs that ran OK under glibc 2.17
>>> started segfaulting under 2.18, and so I dropped back to 2.17.
>>>
>>> I have now tried the experiment of reinstalling version 2.18 and
>>> recompiling the programs that were failing, namely the gvfs
>>> daemons gvfs-mtp-volume-monitor and gvfsd-trash (from gvfs-1.16.3)
>>> and xfdesktop (from Xfce 4.10). Now these programs run OK. Is it
>>> possible there's some subtle ABI incompatibility between these two
>>> glibc versions?
>>
>> All is still not well with 2.18 on my system. I'm now getting a
>> segfault in the Java runtime (which works fine under glibc-2.17). As
>> I mentioned before, the glibc 2.17 that I'm comparing with 2.18 was
>> rebuilt recently using the same gcc version (4.8.1) and kernel
>> headers (3.10.7), and the same options to the configure script.
>>
>> I'm attaching the crash report from the JRE.
>>
>> Allin Cottrell
>
>
> This looks like duplicate of following issue:
>
> http://www.sourceware.org/ml/libc-alpha/2013-08/msg00257.html
>
> Could you check if a fix there helps?

Thanks, it does look like the same issue. I'll try a new build with the
sse4 modification in strstr.c.

Allin Cottrell


More information about the Libc-help mailing list