checking sysdep dirs... configure: error: The arm is not supported

Carlos O'Donell carlos@systemhalted.org
Thu Mar 8 13:52:00 GMT 2012


On Thu, Mar 8, 2012 at 8:15 AM, Hua Li <privatestuffs@gmail.com> wrote:
> Dear Carlos,
>
> Thanks, my cross toolchain is too old, how to upgrade?
>
> I am using linux kernel 3.2.5, which carries GCC 3.2.5, I assume that
> it is not too old.....

Your cross-compiler is too old.

GCC 3.2.5 is almost 10 years old.

I suggest getting a new cross-toolchain, either
via crosstool-ng build[1], the debian ARM EABI port[2], or
a pre-built distribution like that provided by my
employer Mentor Graphics[3].

Cheers,
Carlos.

[1] http://crosstool-ng.org/
[2] http://wiki.debian.org/ArmEabiPort
[3] http://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/



More information about the Libc-help mailing list