Segfaults with eglibc-2.16 on ARM v6 (hardfp)

Stephan Raue
Thu Jul 19 14:06:00 GMT 2012


after upgrading my embedded distribution from eglibc-2.15 to 2.16 i get 
libc related segfaults with every program. Because this distro uses 
shell based init scripts and busybox, which also segfaults provides the 
shell i cant boot into the system with eglibc-2.16. With eglibc-2.15 all 
is working.

I have tried to boot in to a system with eglibc-2.15 and copy the 
eglibc-2.16 filessystem to a writabable location in /storage:
     root ~ # LD_LIBRARY_PATH=/storage/system/lib/ 
     Segmentation fault

if i replace /storage/system/lib/ with the one from eglibc-2.15 
     root ~ # LD_LIBRARY_PATH=/storage/system/lib/ 
     BusyBox v1.20.2 (2012-07-19 08:32:53 CEST) multi-call binary.
     Copyright (C) 1998-2011 Erik Andersen, Rob Landley, Denys Vlasenko

how i can debug this system to get more infos to provide to find the 
issue? i have GDB and STRACE installed on the system, if i run gdb:
     root ~ # gdb /storage/system/bin/busybox
     GNU gdb (GDB)
     (gdb) set environment LD_LIBRARY_PATH=/storage/system/lib/
     (gdb) run
     Starting program: /storage/system/bin/busybox
     During startup program terminated with signal SIGSEGV, Segmentation 
     (gdb) bt
     No stack.

thanks for your help

Stephan Raue

More information about the Libc-help mailing list