[RFC] remove pre gcc-4.0 optimizations

Andreas Jaeger aj@suse.com
Fri Dec 28 12:45:00 GMT 2012


On 12/28/2012 10:39 AM, Ondřej Bílka wrote:
> Hello, I noticed that headers contain optimized versions for gcc as old
> as 2.8 or before.
>
> To simplify code I would remove anything older than 4.0.0 (April 20.2005)
> as it is not relevant today.
>
> Is there a minimal gcc requirement to remove more definitions?

The installed headers should support older GCC versions. I think we 
discussed this in the past (this year) but don't remember the 
resolution, please search the archives,

Andreas
-- 
  Andreas Jaeger aj@{suse.com,opensuse.org} Twitter/Identica: jaegerandi
   SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
    GF: Jeff Hawn,Jennifer Guild,Felix Imendörffer,HRB16746 (AG Nürnberg)
     GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126



More information about the Libc-help mailing list