libgcc_s.so.1 must be installed for pthread_cancel to work

Carlos O'Donell carlos@systemhalted.org
Mon Feb 8 12:18:00 GMT 2010


On Mon, Feb 8, 2010 at 4:44 AM, Mike Frysinger <vapier@gentoo.org> wrote:
> On Monday 08 February 2010 04:32:13 Gabor Z. Papp wrote:
>> * Mike Frysinger <vapier@gentoo.org>:
>> | > Should not this noted somewhere in the README
>> | > (glibc/pthread requires libgcc_s at runtime)?
>> |
>> | probably.  feel free to submit a patch.
>>
>> Attached.
>
> this should be sent to the libc-alpha list with a GNU changelog entry (not to
> the file but posted inline in the e-mail).
>
>> +any Linux kernel prior to 2.6. Also note, that shared version of
>> +libgcc_s library must be installed for pthread to work correctly.
>
> really needs more "the"s in there ...
>
> _the_ shared version
> _the_ libgcc_s
> _the_ pthread _library_
> -mike
>

Some of the checklist may apply to your contribution:
http://sourceware.org/glibc/wiki/Contribution%20checklist

Cheers,
Carlos.



More information about the Libc-help mailing list