FR-V PLT audit

Roland McGrath roland@redhat.com
Thu Feb 10 07:19:00 GMT 2005


> On Wed, Feb 09, 2005 at 10:43:48PM -0800, Roland McGrath wrote:
> > Indeed, what is the motivation for using an anonymous union rather than
> > each sysdeps/CPU/ldsodefs.h defining a macro for the appropriate thing?
> 
> Or any macros at all?  What's so special about the argument and result
> registers that require structure names to differ by target?  We don't
> do that for sigcontext, or jmp_buf.

I think the intent there was just that the structure member names match the
names of the entry point symbols in the audit library.  The reason the API
for those functions uses a different name for each CPU is that the
signature and what you need to know to implement it also differ for each
CPU.  It is not something that is ever used generically like sigcontext and
jmp_buf are.  



More information about the Libc-hacker mailing list