[PATCH] Support LD_USE_LOAD_BIAS

Roland McGrath roland@redhat.com
Sat Nov 22 00:37:00 GMT 2003


> I think LD_USE_LOAD_BIAS shouldn't be honored for suid/sgid, as that way
> a local attacker could disable randomization of a suid PIE and exploit it
> more easily.  This patch is on top of the previously posted one.

I agree.  You should also add it to the unsecvars.h list.

As to the original patch, I don't like the names but otherwise it seems
reasonable to me.  _dl_use_load_bias should be called _dl_load_bias_mask
since you use it that way.  For the environment variable, I think something
like LD_INHIBIT_PRELINK would be better.



More information about the Libc-hacker mailing list