Andrew Pinski <pinskia@gmail.com> writes: >> - count_mask = ~(-1 << (count_mask + 1)); >> + count_mask >> + = ~((unsigned int) -1 << (count_mask + 1)); > > Why not just: > count_mask = ~(-1u << (count_mask + 1)); I agree that is better, thanks. Let me send a v2. Collin